解决安装imagick时Cannot locate header file MagickWand.h的错误

今天在新服上安装php imagick,

环境如下:
php 5.3.20
ImageMagick-6.8.3-8
imagick-3.1.0RC2
可是出错了一个问题.就是死说找不到MagickWand.h:

checking for MagickWand.h header file... configure: error: Cannot locate header file MagickWand.h

可是我明明正确安装了ImageMagick的呀.GOOGLE了半天,也解决不了这个问题.后面对照另一个服务器上的ImageMagick才发现,原来ImageMagick 6.8这个版后的目录结构变了,旧版本头文件是放在/usr/local/include/ImageMagick目录的,而ImageMagick 6.8则是放在/usr/local/include/ImageMagick-6

添加软连接

命令如下:

ln -s /usr/local/include/ImageMagick-6 /usr/local/include/ImageMagick

后来发现imagick-3.1.0RC2编译不通过,于是降低版本,使用imagick-3.01

make && make && install

搞掂!

 

更新:

最终解决方法:

yum install pkgconfig

export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig/

rm -rf Makefile config.status config.h

./configure

make

make install

发表评论?

0 条评论。

发表评论


注意 - 你可以用以下 HTML tags and attributes:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>